Back to overview
Resolved

Latest version of the Desktop application is broken

Aug 24, 2026 at 2:42pm UTC
Affected services
jetstream

Resolved
Aug 24, 2026 at 3:55pm UTC

The issue is now resolved. We pulled the version with the bug and have published a new version which resolves the issue.

If you got stuck on an incorrect version, you will need to manually re-install the latest version:

Windows
https://release-updates.getjetstream.app/jetstream/releases/Jetstream%20Setup%204.12.1.exe

Mac (Apple Silicone)
https://release-updates.getjetstream.app/jetstream/releases/Jetstream-4.12.1-arm64.dmg

Mac (Intel)
https://release-updates.getjetstream.app/jetstream/releases/Jetstream-4.12.1.dmg

We apologize for any inconvenience this may have caused.

Created
Aug 24, 2026 at 2:42pm UTC

Our latest version of the desktop application contains a bug which causes the application to crash after the auto-update is applied.

We are working to resolve the issue and any impacted users will need to manually re-install the latest package version once a fix is published.

We are in the process of reverting our update manifest to avoid auto-updating to the latest version, but this will only help users who have not already auto-updated to the latest version.

We will post more details once they are available.