Google OAuth is unavailable
Resolved
Jun 13, 2026 at 5:57pm UTC
We have resolved the sign in with Google issue. We have created and used a new client id and client secret, so users will be required to re-consent.
We will attempt to revert back to the original client id if possible in case any users had specifically allowed the prior client id.
Incident Details:
While doing some cleanup on Google Cloud Console, an incorrect project was inadvertently deleted, which in turn marked all the API App Registrations to get marked as deleted.
This was discovered shortly after deletion as it broke the Google Drive integration. The deleted project was restored.
Overnight, Google re-deleted the restored project and also deleted all of our App Registrations even though we had previously restored them.
Even after restoring, the App Registrations were unable to be used as they are likely cached in Google's infrastructure. From what information we could find, it appears that it can take 36+ hours for the restore the propagate through Google's infrastructure.
To work around this, we were required to create a new App Registration on a different Google Cloud project.
We apologize for any inconvenience this may have caused.
Affected services
Created
Jun 13, 2026 at 5:06pm UTC
Logging in with Google and Google Drive integration is currently unavailable.
We are working to resolve the issue.
Affected services